Incremental and differential not working properly

Questions about Cobian Backup 11 (Gravity)
Post Reply
Samme
Posts: 1
Joined: 19 Dec 2020, 03:08

Incremental and differential not working properly

Post by Samme »

Hi

I have tried setting up some tasks with both incremental and differential backups every night but the whole process takes longer than it should because it is recopying some unchanged files. Is there a setting I may have missed or something with the files it's recopying?

Thank you
Tatone69
Posts: 10
Joined: 03 Dec 2020, 19:28

Re: Incremental and differential not working properly

Post by Tatone69 »

Regards, do you use Windows?
You can check this in the incremental and differential copied folders:
01 - Select the folder;
02 - Right mouse button click on Properties;
03 - In General, click on Advanced ...;
04 - In the opened window called Advanced attributes, check if the File is ready for archiving is checked.

In both folders, thank you.
backitup
Posts: 2
Joined: 23 Dec 2020, 10:06

Re: Incremental and differential not working properly

Post by backitup »

I have the same problem.
I have a 'Differential' backup task. I notice that after a file is copied to my external backup drive, the option 'File is ready for archiving' is NOT cleared on the original location. But it is set to do so ('Clear archive attribute') in 'Advanced' option of the backup task.
It is my understanding that if the option 'File is ready for archiving' is NOT cleared, it will be copied again (without need) on the next run. Is that correct?
User avatar
cobian
Site Admin
Posts: 833
Joined: 31 Oct 2020, 01:25
Location: Sweden
Contact:

Re: Incremental and differential not working properly

Post by cobian »

A differential backup will NEVER clear the archive attribute . An incremental will.
--
Luis Cobian
Cobian Backup's creator
krysto
Posts: 1
Joined: 25 Aug 2021, 18:40

Re: Incremental and differential not working properly

Post by krysto »

I use Cobian 11 Gravity 11.2.0.582. The latest Windows 10.
I have an Incremental backup task that is set to make a Full backup every 5 backups.
If I start with a fresh clone of that task and run it, I get a Full backup. About 800Mb. Then if I run it again right away (or wait for the next scheduled time) it makes an Incremental backup that is over 500Mb. Even if I have made zero changes to any of the files being backed up. I notice that the 'A' file attribute remains set on most of the source files after the Full backup. What am I missing?

I have other tasks that do a similar Full/Incremental backup plan, and they work as expected.
User avatar
cobian
Site Admin
Posts: 833
Joined: 31 Oct 2020, 01:25
Location: Sweden
Contact:

Re: Incremental and differential not working properly

Post by cobian »

Perhaps you have unchecked the Clear archive attributes on the Advanced tab? That or perhaps the user running the process (the engine) cannot clear the archive attributes of the files.
--
Luis Cobian
Cobian Backup's creator
Robman
Posts: 1
Joined: 04 Sep 2021, 11:23

Re: Incremental and differential not working properly

Post by Robman »

I have also found that incremental does not work for me, doing a full backup every time even though I have the clear archive attribute ticked.
After much frustration and trying every setting and thing I could think of I decided to try differential before just giving up.
Lo and behold differential works perfectly. It only backups up the changed files (cumulatively as expected) and then does a full backup after the specified number of differentials. I still have no idea why incremental does not work. There must be some other setting that is forcing it to do a full backup irrespective of the archive bit value despite it labeling it as an incremental. I can only suggest to try differential for those who have only tried incremental. It is probably the best setting for home users not doing much updating anyway.
User avatar
cobian
Site Admin
Posts: 833
Joined: 31 Oct 2020, 01:25
Location: Sweden
Contact:

Re: Incremental and differential not working properly

Post by cobian »

Differential backup doesn't clear the archive attribute. Incremental does. Perhaps that is the problem: the program is failing to clear the attribute.
--
Luis Cobian
Cobian Backup's creator
NewsRe
Posts: 1
Joined: 22 Oct 2021, 18:04

Re: Incremental and differential not working properly

Post by NewsRe »

Cobian behavior is absolutely correct since Differential backup is always & repeatedly executed against the latest Full backup, therefore the Archive attribute must not be reset being the changed file consistently different from the file backed up by the Full one.
Incremental backup instead is executed against the previous Incremental one, therefore the Archive flag must be reset.
Last edited by NewsRe on 22 Oct 2021, 18:15, edited 2 times in total.
Post Reply