"Make one full every " not working for incremental backup

Questions about Cobian Backup 11 (Gravity)
Post Reply
mike1936
Posts: 2
Joined: 14 Oct 2021, 07:58

"Make one full every " not working for incremental backup

Post by mike1936 »

Hello, everyone.
I want to daily backup a folder to a local LAN server through ftp of type Incremental.
Every 30-th backup to be of Full type and keep 3 full copies at most along the time.

In the pattern like this:
  • day 0 -> full backup
  • day 1~29 -> incremental backup
  • day 30 (first month end) -> full backup
  • day 31~59 -> incremental backup
  • day 60 (2nd month end) -> full backup
  • day 61~89 -> incremental backup
  • Then at day 90(3rd month end), delete all backups from day 0 to day 29, since we are going to make a new full copy and there are already 3 of them, and make a full backup
  • day 91~119 -> incremental
  • so on and so force...
Is that possible to do all of these in Cobian Backup 11 Gravity, or partially, omitting the auto-delete routine? if that is the case, how should I achieve this?

I have already do some testing and the task configs are as follows:
- reduced the task to be execute every minute(btw originally to be daily as intended) so that I could check the result in the ftp server in advance
- make one full every ... SET 3 (30 originally)
- Full copies to keep SET 3
- Create separated backup using timestamps [CHECKED]
- Backup type Incremental [CHECKED]

But it seems that only the first backup is Full, all the following minutes' backups are incremental.

What should I do then, any helps are highly appreciated.
User avatar
cobian
Site Admin
Posts: 522
Joined: 31 Oct 2020, 01:25
Location: Sweden
Contact:

Re: "Make one full every " not working for incremental backup

Post by cobian »

Perhaps the incremental backups have nothing to copy and you have disabled the Save empty backups in the options? Just a theory...
--
Luis Cobian
Cobian Backup's creator
mike1936
Posts: 2
Joined: 14 Oct 2021, 07:58

Re: "Make one full every " not working for incremental backup

Post by mike1936 »

Thx, Luis.

I have done some work around and found out that the "Make one full every ..." does not work for folder uploading through FTP as for my case.
Also I have tried compression with split option 1GB for each (total around 7GB) but for some reason after some tedious waiting of file compressing and file transmitting there are only one 7z file(should be 7~8 of them) uploaded to the local ftp server.

But when I use compression without split options there should be no problem.

So I guess the problem is solved. Yay!
Post Reply