command line events not executed and other problems

Questions about Cobian Reflector
Post Reply
gvd
Posts: 59
Joined: 05 Oct 2021, 16:05
Location: Belgium

command line events not executed and other problems

Post by gvd »

Hello Luis,

1. I have pre-backup events in my backups (still same configuration as yesterday - "Cobian Reflector UI vanishes after a few seconds").
My tasks are imported from Cobian Backup.

Command line : net use y: /delete, Wait for completion: Yes
Pause: 5 second(s)
Command line : net use y: \\... pw /user:usr, Wait for completion: Yes
Pause: 5 second(s)

Cobian Refletor opens an empty command line window and waits until I manually close the window typing "exit".

2. After that, Cobian Reflector states there are errors but shows none of them and ends the backup.

2021-10-16 05:38:29 A backup has started...
2021-10-16 05:38:29 Calculating the number of files. This could take a while...
2021-10-16 05:39:03 Backing up the task "Backup (Tu/Fr-6w-3s)"
2021-10-16 05:39:03 Changing the backup type to full. Reason: first backup of the task.
2021-10-16 05:39:03 Executing the pre-backup events...
2021-10-16 05:39:03 Executing a command line event and waiting for completion... ----- I type "exit" to end the close the CMD window
2021-10-16 05:39:24 The commands have been successfully executed and completed.
2021-10-16 05:39:24 Pausing the working thread 5 second(s)...
2021-10-16 05:39:29 Resuming the working thread after the pause.
2021-10-16 05:39:29 Executing a command line event and waiting for completion... ----- I type "exit" to end the close the CMD window
2021-10-16 05:39:32 The commands have been successfully executed and completed.
2021-10-16 05:39:32 Pausing the working thread 5 second(s)...
2021-10-16 05:39:37 Resuming the working thread after the pause.
2021-10-16 05:39:37 The pre-backup events have been executed.
2021-10-16 05:39:37 Requesting the creation of a Volume Shadow Copy image for the source...
2021-10-16 05:39:42 The Volume Shadow Copy image has been successfully deleted. :!:
2021-10-16 05:39:42 The backup has ended. There are errors. Consult the log file. :!:

2021-10-16 05:39:43 The log files have been successfully deleted.

3. The two lines marked :!: above are not sent in the mail report although I requested to send the log files "when a task is done".

4. In my imported tasks, object of the mail is defined as "[%COMPUTERNAME] (%DATENOTIME) - %TASKNAME" but taskname does not show up in the object of the mail sent after completion of the task.

5. %DATETIME : the date format in the object of the mail has been reversed between Cobian Backup (16/10/2021) and Reflector (2021-10-16).
I suppose this is bound to the "Date/Time format for the log" that existed in Cobian Backup and not anymore in Reflector.
"This is not a bug, it's a feature" :-).
We'll get used to it.

6. In the "event" settings of the task, when I select an event and use the arrows (< >) to scroll, after some clicks (sometimes, one is enough), the edit window shows up as if I had clicked on the "edit" button.
This does not occur when no event is seleted or when I use the scroll handle.

Have fun ;)
Gabriel
Evangelist :roll:
User avatar
cobian
Site Admin
Posts: 843
Joined: 31 Oct 2020, 01:25
Location: Sweden
Contact:

Re: command line events not executed and other problems

Post by cobian »

Hola

Cobian Refletor opens an empty command line window and waits until I manually close the window typing "exit".
Have you tried using /C NET USE... etc ?
2. After that, Cobian Reflector states there are errors but shows none of them and ends the backup.
My guess is that the program never gets back the exit code 0 because you were not using /C. But that's only a guess.
3. The two lines marked :!: above are not sent in the mail report although I requested to send the log files "when a task is done".
I see. That's because you are sending the log file "when the task is done". In that case the log is send before the VSC is deleted. Use "When the backup is done instead, but then you will not have a Task name... Hmm... I'll see what could be done.
4. In my imported tasks, object of the mail is defined as "[%COMPUTERNAME] (%DATENOTIME) - %TASKNAME" but taskname does not show up in the object of the mail sent after completion of the task.
Already fixed for the next version
5. %DATETIME : the date format in the object of the mail has been reversed between Cobian Backup (16/10/2021) and Reflector (2021-10-16).
I suppose this is bound to the "Date/Time format for the log" that existed in Cobian Backup and not anymore in Reflector.
"This is not a bug, it's a feature" :-).
We'll get used to it.
You could use %FORMATDATETIME instead. This will respect the format used in Advanced.
6. In the "event" settings of the task, when I select an event and use the arrows (< >) to scroll, after some clicks (sometimes, one is enough), the edit window shows up as if I had clicked on the "edit" button.
This does not occur when no event is seleted or when I use the scroll handle.
Will check that out.

Thanks!
--
Luis Cobian
Cobian Backup's creator
gvd
Posts: 59
Joined: 05 Oct 2021, 16:05
Location: Belgium

Re: command line events not executed and other problems

Post by gvd »

cobian wrote: 16 Oct 2021, 12:05Have you tried using /C NET USE... etc ?
1. "/c " in front of the command helps (but was not needed in Cobian Backup).
cobian wrote: 16 Oct 2021, 12:05My guess is that the program never gets back the exit code 0 because you were not using /C. But that's only a guess.
2. I now have other problems (access denied :o ) I must solve before I can check whether the errors disappeared with the "/c".
cobian wrote: 16 Oct 2021, 12:05Use "When the backup is done" instead, but then you will not have a Task name... Hmm... I'll see what could be done.
3. I do not have the option "When the backup is done" :?.
cobian wrote: 16 Oct 2021, 12:05Already fixed for the next version
4. Thanks.
cobian wrote: 16 Oct 2021, 12:05You could use %FORMATDATETIME instead. This will respect the format used in Advanced.
5. Bad luck ! I use yyyy/mm/dd for the directory names and dd/mm/yyyy for the mail object. I'll have get used to yyyy/mm/dd for the mail object too.

Thanks.
Gabriel
Evangelist :roll:
Post Reply