Scheduled backup did not trigger

Questions about Cobian Reflector
przemhb
Posts: 16
Joined: 23 Sep 2021, 10:50

Scheduled backup did not trigger

Post by przemhb »

Today I received a notification about new version of the Cobian Reflector. I was very glad to read bugs I've reported were fixed. I've updated the Reflector immediately.
To my surprise none of my 4 backups scheduled for Mondays 20:00 triggered. Log (below) doesn't show any clue why.

Code: Select all

    2021-09-27 18:18:22 Welcome to Cobian Reflector
    2021-09-27 18:18:22 Loading the task list "C:\Program Files\tools\Cobian Reflector\Lists\MainList.lst".
    2021-09-27 18:56:00 Checking for updates...
ERR 2021-09-27 18:56:00 A new version is available!
    2021-09-27 18:56:00 
    2021-09-27 18:56:00 Current version: 0.9.05 BETA
    2021-09-27 18:56:00 
    2021-09-27 18:56:00 * The colors of the user interface can now be customized
    2021-09-27 18:56:00 * When a task is started, the name of the user executing the task is now logged
    2021-09-27 18:56:00 * Fixed a bug when logging the file name of a monolithic zip
    2021-09-27 18:56:00 * Fixed a bug with monolithic directories that have names that begin begin with a dot
    2021-09-27 18:56:00 * Absolute paths can now be included even in monolithic archives
    2021-09-27 18:56:00 * Some context menu items didn't translate. Fixed
    2021-09-27 18:56:00 * Fixed a bug while uploading files with absolute paths
    2021-09-27 18:56:00 * Fixed the real path of a monolithic archive when using absolute paths
    2021-09-27 18:56:00 * Log files can now be mailed in the body of the message and not only as attachments
    2021-09-27 18:56:00 * Some example of command line is now provided
    2021-09-27 18:56:00 
    2021-09-27 18:56:00 You can visit the program's website to download the new version.
    2021-09-27 18:56:00 Download it at: https://www.cobiansoft.com/cobianbackup.html.
    2021-09-27 18:56:00 
ERR 2021-09-27 19:07:42 An error has occurred in the pipe connection: Potok jest przerwany..
    2021-09-27 19:07:44 Closing the engine. Bye!
ERR 2021-09-27 19:07:44 An error has occurred in the pipe connection: Potok jest przerwany..
    2021-09-27 19:08:51 Welcome to Cobian Reflector
    2021-09-27 19:08:51 Loading the task list "C:\Program Files\tools\Cobian Reflector\Lists\MainList.lst".
    2021-09-27 19:10:28 The list "MainList.lst" has been successfully saved.
    2021-09-27 19:10:33 The list "MainList.lst" has been successfully saved.
    2021-09-27 19:11:36 The settings have been changed and saved. 
    2021-09-27 19:11:36 A new language is being used: english.
    2021-09-27 19:11:44 The list "MainList.lst" has been successfully saved.
    2021-09-27 20:05:28 Checking for updates...
    2021-09-27 20:05:28 Your program is up to date.
    2021-09-27 20:05:55 The list "MainList.lst" has been successfully saved.
User avatar
cobian
Site Admin
Posts: 488
Joined: 31 Oct 2020, 01:25
Location: Sweden
Contact:

Re: Scheduled backup did not trigger

Post by cobian »

Are those tasks scheduled as weekly backups?
--
Luis Cobian
Cobian Backup's creator
przemhb
Posts: 16
Joined: 23 Sep 2021, 10:50

Re: Scheduled backup did not trigger

Post by przemhb »

Yes, weekly, Mondays 20:00.
User avatar
cobian
Site Admin
Posts: 488
Joined: 31 Oct 2020, 01:25
Location: Sweden
Contact:

Re: Scheduled backup did not trigger

Post by cobian »

Tested here. Works OK... Interesting. I see the broken pipe error: Potok jest przerwany..I wonder what it's causing it and if it has something to do with this.
--
Luis Cobian
Cobian Backup's creator
przemhb
Posts: 16
Joined: 23 Sep 2021, 10:50

Re: Scheduled backup did not trigger

Post by przemhb »

The broken pipe error happened before I have installed .005 Reflector or during the installation. Then the Reflector was re-started.
When I have noticed my tasks didn't fire I've added a second, later start times, but it didn't help. Still those tasks weren't triggered.

Today when I started Windows the Reflector fired 3 out of 4 missed backups and completed them, as I've got "run missed backups" checked. The first from the list was omitted. I have no idea why.

Today I have updated to .006 and manually run the 1st task. I will let you know if it helped.
przemhb
Posts: 16
Joined: 23 Sep 2021, 10:50

Re: Scheduled backup did not trigger

Post by przemhb »

One thing that pops into my mind is that, the particular task differs from the others in a way that destination drive is unmounted (no drive letter) up until the moment pre-backup event awakes it and mounts it.

I've cloned the task. It doesn't trigger, no matter what time I set.
I've unchecked both "cancel the task if some event fails" and "do not execute if pre-backup events failed". It didn't help. Removing pre and post event neither.

The task is imported from Cobian Backup 11 which handled it flawlessly.
User avatar
cobian
Site Admin
Posts: 488
Joined: 31 Oct 2020, 01:25
Location: Sweden
Contact:

Re: Scheduled backup did not trigger

Post by cobian »

Interesting... I'll try to replicate this issue. Do you mount the source with NET USE?
--
Luis Cobian
Cobian Backup's creator
przemhb
Posts: 16
Joined: 23 Sep 2021, 10:50

Re: Scheduled backup did not trigger

Post by przemhb »

No, I don't use NET USE. It's an internal HDD, which I unmount, put to sleep power mode and wake only when needed. Example commands are as given below.

To unmount and change power mode to sleep:
"C:\Windows\System32\mountvol.exe" F: /P
"SeaChest_PowerControl_x64_windows.exe" -d PD0 --transitionPower=sleep

To wake and mount:
"SeaChest_PowerControl_x64_windows.exe" -d PD0 --transitionPower=active
"C:\Windows\System32\mountvol.exe" F: \\?\Volume{f81f8bc9-a8ff-11e2-bc6c-806e6f6e6963}\

SeaChest is a freeware utility from Seagate. Most of its commands works with any HDDs. To check appropriate PDx run:
"SeaChest_PowerControl_x64_windows.exe" -s
przemhb
Posts: 16
Joined: 23 Sep 2021, 10:50

Re: Scheduled backup did not trigger

Post by przemhb »

I've checked if having the HDD mounted when the task is about to be triggered helps. It doesn't.
User avatar
cobian
Site Admin
Posts: 488
Joined: 31 Oct 2020, 01:25
Location: Sweden
Contact:

Re: Scheduled backup did not trigger

Post by cobian »

And you are not getting ANY clue in the log file? Try setting the log to Verbose mode and see if you het any more info.
--
Luis Cobian
Cobian Backup's creator
Post Reply