Scheduled backup did not trigger

Questions about Cobian Reflector
przemhb
Posts: 16
Joined: 23 Sep 2021, 10:50

Re: Scheduled backup did not trigger

Post by przemhb »

No, there wasn't any clue. Nothing related to the particular task appeared in the log file.

I set verbose log mode and added Thursday 0:30 for test a minute before the time. Surprisingly it fired with numerous log entries.
As the issue couldn't be affected nor caused by log mode set I will test the task further.
AxeR
Posts: 7
Joined: 04 Oct 2021, 17:25

Re: Scheduled backup did not trigger

Post by AxeR »

Hi, sorry to jump in on a week-old thread but I'm facing the same issue, but I mount the drive with net use.
Attachments
Log files for Cobian Reflector.zip
(6.29 KiB) Downloaded 20 times
User avatar
cobian
Site Admin
Posts: 526
Joined: 31 Oct 2020, 01:25
Location: Sweden
Contact:

Re: Scheduled backup did not trigger

Post by cobian »

I think I've found why the "Pipe is broken" error is produced. Thank you.
--
Luis Cobian
Cobian Backup's creator
przemhb
Posts: 16
Joined: 23 Sep 2021, 10:50

Re: Scheduled backup did not trigger

Post by przemhb »

I've got a clue why the backup failed to trigger. I've got 4 tasks and each of them is set to trigger weekly, on Monday at 20:00.
Today triggered only the first one. The remaining were ignored.
Maybe they haven't been queued and will be triggered later as a missed ones?
User avatar
cobian
Site Admin
Posts: 526
Joined: 31 Oct 2020, 01:25
Location: Sweden
Contact:

Re: Scheduled backup did not trigger

Post by cobian »

They should have started.... I will simulate this case tomorrow.
--
Luis Cobian
Cobian Backup's creator
User avatar
cobian
Site Admin
Posts: 526
Joined: 31 Oct 2020, 01:25
Location: Sweden
Contact:

Re: Scheduled backup did not trigger

Post by cobian »

Have now tested this issue: 4 weekly tasks with the same time and day. All four are executed without problems.

Can you tell me exact what schedule your task have?
--
Luis Cobian
Cobian Backup's creator
przemhb
Posts: 16
Joined: 23 Sep 2021, 10:50

Re: Scheduled backup did not trigger

Post by przemhb »

I reckon it will be the best just to share my MainList.lst file with all the tasks.
MainList.7z
(5.83 KiB) Downloaded 21 times
User avatar
cobian
Site Admin
Posts: 526
Joined: 31 Oct 2020, 01:25
Location: Sweden
Contact:

Re: Scheduled backup did not trigger

Post by cobian »

I have now imported your list and simulated a backup... It seems there is a problem with your Pre-event which pauses the working thread for 624 seconds. This causes some weird effects that I need to debug.
--
Luis Cobian
Cobian Backup's creator
User avatar
cobian
Site Admin
Posts: 526
Joined: 31 Oct 2020, 01:25
Location: Sweden
Contact:

Re: Scheduled backup did not trigger

Post by cobian »

I have now debugged the list and yes, all the tasks are executed, but the first one is holding the rest for 10 minutes (don't know the reason for this pre-backup event)...
--
Luis Cobian
Cobian Backup's creator
przemhb
Posts: 16
Joined: 23 Sep 2021, 10:50

Re: Scheduled backup did not trigger

Post by przemhb »

The reason is to give HDD time to perform Short DST before backup. DST is required because I have disabled the drive's internal background media scan. During BGMS drive checks health of its surface. The data is later used for SMART. Once it is disabled I need to take care for it manually. Short DST checks 1/10th of the surface at a time. It takes 10 minutes, hence the 624 seconds.
If you're wondering why I have disabled BGMS it simple - to keep the drive quiet. It is used solely for backups. Unfortunately when it operates it gets quite noisy. And BGMS is started when the drive gets idle. There are no means to control this.

Anyhow the last time only the first backup task triggered, the one with the 10m hold pre-backup event. Until Midnight on Monday no other was executed and in the following two days remaining tasks were not triggered despite the fact Reflector is set to run missed backups.
On the other hand when I turned on my PC too late for the backup to start in preset time in the recent weeks, at least one missed backup started.
Post Reply