Adjust First time backup behavior - RESOLVED

Questions about Cobian Backup
Post Reply
BzKevin
Posts: 2
Joined: Sun Sep 15, 2019 9:15 pm

Adjust First time backup behavior - RESOLVED

Post by BzKevin » Wed Sep 18, 2019 4:52 am

Hello all,

I am new to Cobian backup and have tried to read, but have failed to find my solution. Here is my setup:

I have an external drive connected to my PC. There is a folder there called "Pictures" which houses terrabytes of images, along with small associated files generated and modified by my image editing software (anytime I make edits this small associated file is updated, but the source image remains unchanged). I have unlimited google drive storage, mounted as G: drive. I have already made a one-for-one copy of all my files from my external drive to google drive (as of two days ago), but in the future I would like for any modified or new files to automatically by copied from my external drive to G:. Quite simply, I want G:/Pictures to mirror D:/Pictures.

I set up a task to run on startup that has:
Source: D:\Pictures
Dest.: G:\My Drive\UnSync\Pictures
Incl. Sub Dirs: Yes
Separated Backups: No
Use Attr.: Yes
Use Abs. Paths: No
Always create top parent dir.: No
Clear Archive attr.: Yes

I have also gone in and uncheck Options>Engine>"First backup always full"

However, everytime Cobian starts up it begins attempting to sync every file from D:\Pictures to the google drive directory. Given I have terrabytes of data already synced and up-to-date I'd like to know what I can do to ensure ONLY FUTURE CHANGES (including changes to files already existing, or new files added to the Pictures folder or its sub-dirs.

Hopefully I've provided you all with the info you need to help me, if not let me know what else you need or what suggestions you have.

Thanks!

(Also, major thanks to Luis Cobian for creating this program and providing it to the world free of charge, AND for continuing to support the users!!)
Last edited by BzKevin on Sat Sep 28, 2019 3:02 pm, edited 1 time in total.

BzKevin
Posts: 2
Joined: Sun Sep 15, 2019 9:15 pm

Re: Adjust First time backup behavior

Post by BzKevin » Sat Sep 28, 2019 3:01 pm

I was able to resolve this issue. As I had manually copied all my files to G: the Archive bit in file properties had not been reset. Thus, when running the backup, Cobian rightfully attempted to backup all the files because the archive bit was high.

To quickly reset the bit I used MultiCommander, which has a handy tool allowing you to reset the archive bit of every file in a folder and sub-folders with a single dialog box.

User avatar
cobian
Site Admin
Posts: 168
Joined: Fri Mar 22, 2019 8:57 pm
Location: Umeå, Sweden
Contact:

Re: Adjust First time backup behavior - RESOLVED

Post by cobian » Tue Oct 08, 2019 8:32 pm

Great! You could also have used Task-Reset archive attributes. It does the same thing as far as I know.
--
Luis Cobian
Cobian Backup's creator and Developer
https://www.cobiansoft.com

Post Reply