Mistery : backup done but empty (only on some machines...all others works)

Questions about Cobian Backup
Post Reply
Marco
Posts: 5
Joined: Thu Jun 20, 2019 1:22 pm

Mistery : backup done but empty (only on some machines...all others works)

Post by Marco » Mon Jun 24, 2019 11:39 pm

Hi guys.
My name is Marco and I'm writing from Italy.
I'm a Cobian Bakup user since 2007 and I never had a problem until last month.
I have 5 pc, same brand, same model, same master image and windows update release. Identical.
Each pc has multiple userprofiles, each one wit about 1 Gb of data locate in desktop/documents/picture folders.
Each pc has a secondary Hard Disk with a single folder inside called "BackupFolder" with Everyone FullAccess permission set-
The backup task is executed with a local user called "Installatore" with full right on all userprofiles folders.

On three of theese PC Cobian is working perfectly. On the other two pcs Cobian is unable to backup.
The backup task is the same for all 5 pc. I've tried to export backup task from a woking pc and import the task on a not working pc...no success. I disabled antivirus and UAC Control, checked all folders permissions...but no luck.

When backup start Cobian start calculating Files and Folders to backup...the result is 0 byte.
When backup finish the result is "Errors: 0. Processed files: 1. Backed up files: 0. Total size: 0 bytes "

This is the operatng system version :

- Windows 10 Professional version 1803 (build 17134.829)

Last Cobian Backup's LOG :

2019-06-20 13:04 *** A new backup has started. Number of tasks in queue: 1 ***
2019-06-20 13:04 Preventing the system from entering sleep mode...
2019-06-20 13:04 ** Backing up the task "DailyBackup" **
2019-06-20 13:04 Counting the files for the task "DailyBackup"...
2019-06-20 13:04 Impersonating the user ".\Installatore" to run the task "DailyBackup"...
2019-06-20 13:04 The user ".\Installatore" has now logged on
2019-06-20 13:04 The task is now being executed as the user ".\Installatore"
2019-06-20 13:04 If your unpacker cannot handle the archives created by Cobian Backup, see the FAQ
2019-06-20 13:04 Starting the Volume Shadow Copy snapshot for the drives: C:\
2019-06-20 13:06 The Volume Shadow Copy snapshot set has been created successfully
2019-06-20 13:06 Ignoring the source "GLOBALROOT\Device\HarddiskVolumeShadowCopy15\Users\All Users\": found in the task's exclusion masks
2019-06-20 13:06 Ignoring the source "GLOBALROOT\Device\HarddiskVolumeShadowCopy15\Users\Default\": found in the task's exclusion masks
2019-06-20 13:06 Ignoring the source "GLOBALROOT\Device\HarddiskVolumeShadowCopy15\Users\Default User\": found in the task's exclusion masks
2019-06-20 13:06 Ignoring the source "GLOBALROOT\Device\HarddiskVolumeShadowCopy15\Users\Installatore\": found in the task's exclusion masks
2019-06-20 13:06 Ignoring the source "GLOBALROOT\Device\HarddiskVolumeShadowCopy15\Users\Public\": found in the task's exclusion masks
2019-06-20 13:06 Nothing to compress
2019-06-20 13:06 The history file for "DailyBackup" will not be saved because the result of the backup is empty
2019-06-20 13:06 Deleting the Volume Shadow Copy snapshot "108a9e8a-ed64-45c7-9811-ffd550b3037d"
2019-06-20 13:06 The Volume Shadow Copy snapshot set has been successfully deleted
2019-06-20 13:06 Reverting the working thread to run under the original user account
2019-06-20 13:06 The working thread is now running under the original user account
2019-06-20 13:06 Total backup time for "DailyBackup": 0 hours, 2 minutes, 6 seconds
2019-06-20 13:06 ** Backup done for the task "DailyBackup". Errors: 0. Processed files: 1. Backed up files: 0. Total size: 0 bytes **
2019-06-20 13:06 --
2019-06-20 13:06 The system can now enter sleep mode
2019-06-20 13:06 Total backup time: 0 hours, 2 minutes, 10 seconds
2019-06-20 13:06 *** Backup done. Errors: 0. Processed files: 1. Backed up files: 0. Total size: 0 bytes ***
2019-06-20 13:06 --

CobianBackup's MainList.lst file (features : daily backup, excecuted from admin user with access to all local profiles on the disk, with exclusion mask to avoid backup of some default profiles, inclusion mask to limit backup to Desktop, Documents, Favourites and pictures folder, encryption with passphrase, backup on secondary hard disk in a dedicated folder with Everyone full access permission set) :

{11//
Id={0BF231CC-C411-4998-A52A-C0252174DB98}
Name=DailyBackup
Group=
Enabled=true
Include subdirectories=true
Create separated backups=true
Use attributes=true
Use VSC=true
Backup type=2
Priority=0
Source="1,C:\Users"
Destination="1,D:\BackupData"
Schedule type=1
Select days of the week=false
Order of Day of the week=1
Day of the week=1
Date/Time=0100000011100101000100000011000000000000000001101010110011001010
Day of the month=1
Month=1
Timer=180
Timer from=0100000011100101000100000010000000000000000000000000000000000000
Timer to=0100000011100101000100000011111111111111111001111011101000110111
Full copies=1
Differental copies=20
One full every=21
Use fixed day=false
Fixed day=1
Compression=1
Compress individually=false
Split=0
Custom size=4300000000
Comment=Cobian Backup 11 Gravity
Encryption=3
Passphrase=eAB0AHgAfgBwAGUAeQByAHYAcwAwAGwAGgALABwAcgB6ACEAdgBfAAgALQBlADUAaABHABMAQwBwAEwAdgBJAGMAFABoAHIAGABzAG4AcgB1AHEAfgAEAH4ACAADAE0AawBTAAwAVQAJAHIAPQABAG4AUAAOACwAAQAKAC4AGAAlAH4AZwB0AGEAdAB3AHgA
Exclusions="1,C:\Users\BackupOperator,0,0000000000000000000000000000000000000000000000000000000000000000","1,C:\Users\Installatore,0,0000000000000000000000000000000000000000000000000000000000000000","1,C:\Users\Public,0,0000000000000000000000000000000000000000000000000000000000000000","1,""C:\Users\Default User"",0,0000000000000000000000000000000000000000000000000000000000000000","1,C:\Users\Default,0,0000000000000000000000000000000000000000000000000000000000000000","1,""C:\Users\All Users"",0,0000000000000000000000000000000000000000000000000000000000000000"
Inclusions="3,*\Desktop\*\,0,0000000000000000000000000000000000000000000000000000000000000000","3,*\Documents\*\,0,0000000000000000000000000000000000000000000000000000000000000000","3,*\Favourites\*\,0,0000000000000000000000000000000000000000000000000000000000000000","3,*\Downloads\*\,0,0000000000000000000000000000000000000000000000000000000000000000","3,*\Pictures\*\,0,0000000000000000000000000000000000000000000000000000000000000000"
Pre backup events=
Post backup events=
Abort if pre-event fails=false
Abort if post-event fails=false
Mirror=false
Absolute paths=false
Always create top directory=true
Clear archive attribute=true
Include backup type=true
Delete empty directories=true
Impersonate=true
Abort if impersonation fails=false
Run as User name=Installatore
Run as Domain=.
Run as Password=YQB/AHQAawBpAHsAZgB7AGcAbAApAHQAGwALABcAcgByACEAZgBfAAMALQB/ADUAZQBHABIAQwB4AEwAbQBJAGMAFAB+AHIAGQBzAGAAcgBiAHEAdwAEAGUACAADAE0AegBTAAkAVQASAHIAJgABAG4AUAALACwACgAEADcADQAyAGkAcwB5AGIAZwB5AHkA
//11}

It does not make sense. I'm going crazy. Please help me to understand where is the problem !!!

Thank you

Marco

User avatar
cobian
Site Admin
Posts: 135
Joined: Fri Mar 22, 2019 8:57 pm
Location: Umeå, Sweden
Contact:

Re: Mistery : backup done but empty (only on some machines...all others works)

Post by cobian » Mon Jul 01, 2019 12:51 am

If you disable compression for the 2 pcs that are not working, does the backup get executed correctly? I'm guessing it could be some problem with the zip engine (problem with the temporary directory or something else).
--
Luis Cobian
Cobian Backup's creator and Developer
https://www.cobiansoft.com

Marco
Posts: 5
Joined: Thu Jun 20, 2019 1:22 pm

Re: Mistery : backup done but empty (only on some machines...all others works)

Post by Marco » Wed Jul 03, 2019 2:21 pm

Hi!
I'll try tomorrow and I'll come back with an answer!

Thank you for your reply!

Best regards

Marco
Posts: 5
Joined: Thu Jun 20, 2019 1:22 pm

Re: Mistery : backup done but empty (only on some machines...all others works)

Post by Marco » Wed Jul 03, 2019 4:28 pm

Hi. I have just completed some test on non workin' machines :

- Removed any kind of compression : test KO
- Added 7-zip compression : test KO
- removed encryption and relative KEY : test KO

Backup folder is still empty.

User avatar
cobian
Site Admin
Posts: 135
Joined: Fri Mar 22, 2019 8:57 pm
Location: Umeå, Sweden
Contact:

Re: Mistery : backup done but empty (only on some machines...all others works)

Post by cobian » Tue Jul 09, 2019 10:48 pm

Try fixing the permissions on the sources of those machines: Tools-Reset permissions and see if it helps.
--
Luis Cobian
Cobian Backup's creator and Developer
https://www.cobiansoft.com

Marco
Posts: 5
Joined: Thu Jun 20, 2019 1:22 pm

Re: Mistery : backup done but empty (only on some machines...all others works)

Post by Marco » Thu Jul 11, 2019 1:15 pm

I've tried...no luck :cry:

Size : 0 bytes
Backup Folder : empty

User avatar
cobian
Site Admin
Posts: 135
Joined: Fri Mar 22, 2019 8:57 pm
Location: Umeå, Sweden
Contact:

Re: Mistery : backup done but empty (only on some machines...all others works)

Post by cobian » Sun Jul 21, 2019 9:48 pm

Is the program running as a service? Change the installation type to application in that case and try again.
--
Luis Cobian
Cobian Backup's creator and Developer
https://www.cobiansoft.com

Marco
Posts: 5
Joined: Thu Jun 20, 2019 1:22 pm

Re: Mistery : backup done but empty (only on some machines...all others works)

Post by Marco » Thu Jul 25, 2019 5:13 pm

Hi. I've tried to change the installation type to application with no luck.

But I have a little good news…

The backup task is executed with a local user called "Installatore" with full right on all userprofiles folders.
This user is member of local "administrators" group.
In my test lab I've a Windows Domain. I've tried to change the local user "Installatore" with a domain user (that is standard user, not "domain admin") but is member of local "Administrators" group.

It seems to work...but I cannot understand why!

And I cannot understand why on the three twin computers all works good with user "installatore"...

Thank you for your help!

User avatar
cobian
Site Admin
Posts: 135
Joined: Fri Mar 22, 2019 8:57 pm
Location: Umeå, Sweden
Contact:

Re: Mistery : backup done but empty (only on some machines...all others works)

Post by cobian » Fri Jul 26, 2019 11:24 am

Interesting. This seems to be a problem of permissions between the local user and the domain policy in some computers...
--
Luis Cobian
Cobian Backup's creator and Developer
https://www.cobiansoft.com

deps
Posts: 1
Joined: Tue Jul 09, 2019 11:53 am

Re: Mistery : backup done but empty (only on some machines...all others works)

Post by deps » Thu Aug 15, 2019 3:42 pm

Hello
I have a same problem and investigate it more deeper.
I found that the problem appears only if "zip compression" and "use file attribute logic" are selected.
The "backup type" does not affected.

I tried to backed up same directory with Zip,7-zip and no compression options and only zip compression skiped the files.
Please see screenshot.
all files with same permissions.

Image

I think the Full version should not check A attribute.

Post Reply